<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: https://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">

	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.13.1/css/all.min.css">
	
	
<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>Motivation fuels the action in Dolph Lundgren&#039;s &#039;Castle Falls&#039; - Metro Philadelphia</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Motivation fuels the action in Dolph Lundgren&#039;s &#039;Castle Falls&#039; - Metro Philadelphia" />
<meta property="og:description" content="&lt;div class=&quot;at-above-post addthis_tool&quot; data-url=&quot;https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/&quot;&gt;&lt;/div&gt;Dolph Lundgren, Scott Adkins and a crew of desperate characters are all on the hunt for stolen money inside a building timed for destruction in the latest action-packed feature, &#8220;Castle Falls.&#8221; Directed by Lundgren, the story centers on people who are in desperate situations and audiences get to see firsthand what they will do for [&hellip;]&lt;!-- AddThis Advanced Settings above via filter on get_the_excerpt --&gt;&lt;!-- AddThis Advanced Settings below via filter on get_the_excerpt --&gt;&lt;!-- AddThis Advanced Settings generic via filter on get_the_excerpt --&gt;&lt;!-- AddThis Share Buttons above via filter on get_the_excerpt --&gt;&lt;!-- AddThis Share Buttons below via filter on get_the_excerpt --&gt;&lt;div class=&quot;at-below-post addthis_tool&quot; data-url=&quot;https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/&quot;&gt;&lt;/div&gt;&lt;!-- AddThis Share Buttons generic via filter on get_the_excerpt --&gt;" />
<meta property="og:url" content="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/" />
<meta property="og:site_name" content="Metro Philadelphia" />
<meta property="article:tag" content="Entertainment" />
<meta property="article:tag" content="movies" />
<meta property="article:section" content="Entertainment" />
<meta property="og:image" content="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1200x675.jpg" />
<meta property="og:image:secure_url" content="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1200x675.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="Motivation fuels the action in Dolph Lundgren&#8217;s &#8216;Castle Falls&#8217;" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Motivation fuels the action in Dolph Lundgren&#039;s &#039;Castle Falls&#039; - Metro Philadelphia" />
<meta name="twitter:description" content="&lt;div class=&quot;at-above-post addthis_tool&quot; data-url=&quot;https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/&quot;&gt;&lt;/div&gt;Dolph Lundgren, Scott Adkins and a crew of desperate characters are all on the hunt for stolen money inside a building timed for destruction in the latest action-packed feature, &#8220;Castle Falls.&#8221; Directed by Lundgren, the story centers on people who are in desperate situations and audiences get to see firsthand what they will do for [&hellip;]&lt;!-- AddThis Advanced Settings above via filter on get_the_excerpt --&gt;&lt;!-- AddThis Advanced Settings below via filter on get_the_excerpt --&gt;&lt;!-- AddThis Advanced Settings generic via filter on get_the_excerpt --&gt;&lt;!-- AddThis Share Buttons above via filter on get_the_excerpt --&gt;&lt;!-- AddThis Share Buttons below via filter on get_the_excerpt --&gt;&lt;div class=&quot;at-below-post addthis_tool&quot; data-url=&quot;https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/&quot;&gt;&lt;/div&gt;&lt;!-- AddThis Share Buttons generic via filter on get_the_excerpt --&gt;" />
<meta name="twitter:image" content="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1200x675.jpg" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://metrophiladelphia.com/#organization","name":"Metro Philly","url":"https://metrophiladelphia.com","logo":{"@type":"ImageObject","@id":"https://metrophiladelphia.com/#logo","url":"https://philly.metro.us/wp-content/uploads/2021/04/12370901_1190151520998562_8911266993734335932_o.png","caption":"Metro Philly","inLanguage":"en-US","width":"500","height":"180"}},{"@type":"WebSite","@id":"https://metrophiladelphia.com/#website","url":"https://metrophiladelphia.com","name":"Metro Philly","publisher":{"@id":"https://metrophiladelphia.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-scaled.jpg","url":"https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-scaled.jpg","width":"2560","height":"1440","inLanguage":"en-US"},{"@type":"Person","@id":"https://metrophiladelphia.com/author/molly-given/","name":"Molly Given","url":"https://metrophiladelphia.com/author/molly-given/","image":{"@type":"ImageObject","@id":"https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png","url":"https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png","caption":"Molly Given","inLanguage":"en-US"},"worksFor":{"@id":"https://metrophiladelphia.com/#organization"}},{"@type":"WebPage","@id":"https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/#webpage","url":"https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/","name":"Motivation fuels the action in Dolph Lundgren&#039;s &#039;Castle Falls&#039; - Metro Philadelphia","datePublished":"2021-11-29T13:50:22-05:00","dateModified":"2021-11-29T13:50:22-05:00","author":{"@id":"https://metrophiladelphia.com/author/molly-given/"},"isPartOf":{"@id":"https://metrophiladelphia.com/#website"},"primaryImageOfPage":{"@id":"https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-scaled.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Motivation fuels the action in Dolph Lundgren&#039;s &#039;Castle Falls&#039; - Metro Philadelphia","datePublished":"2021-11-29T13:50:22-05:00","dateModified":"2021-11-29T13:50:22-05:00","author":{"@id":"https://metrophiladelphia.com/author/molly-given/"},"publisher":{"@id":"https://metrophiladelphia.com/#organization"},"description":"Dolph Lundgren, Scott Adkins and a crew of desperate characters are all on the hunt for stolen money inside a building timed for destruction in the latest action-packed feature, \"Castle Falls.\" Directed by Lundgren, the story centers on people who are in desperate situations and audiences get to see firsthand what they will do for money.","name":"Motivation fuels the action in Dolph Lundgren&#039;s &#039;Castle Falls&#039; - Metro Philadelphia","@id":"https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/#richSnippet","isPartOf":{"@id":"https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/#webpage"},"image":{"@id":"https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-scaled.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel="amphtml" href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/amp/" /><meta name="generator" content="AMP for WP 1.0.77.29"/><link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/metrophiladelphia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://metrophiladelphia.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='schneps-rest-post-pusher-css'  href='https://metrophiladelphia.com/wp-content/plugins/schneps-rest-post-pusher/public/css/schneps-rest-post-pusher-public.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='main_stylesheet-css'  href='https://metrophiladelphia.com/wp-content/plugins/spotim-comments/assets/stylesheets/main.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://metrophiladelphia.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='theme-css-css'  href='https://metrophiladelphia.com/wp-content/themes/schnepstheme/build/main.86f628a59ede2d7b2eda.css' type='text/css' media='all' />
<style id='theme-css-inline-css' type='text/css'>
header .hamburger{display:flex}@media screen and (max-width:1420px){
					nav.main-nav ul.nav-menu-items .nav-1{display:none}
				}
				@media screen and (max-width:1535px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-1{display:none}
				}
				@media screen and (max-width:1308px){
					nav.main-nav ul.nav-menu-items .nav-2{display:none}
				}
				@media screen and (max-width:1423px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-2{display:none}
				}
				@media screen and (max-width:1196px){
					nav.main-nav ul.nav-menu-items .nav-3{display:none}
				}
				@media screen and (max-width:1311px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-3{display:none}
				}
				@media screen and (max-width:1084px){
					nav.main-nav ul.nav-menu-items .nav-4{display:none}
				}
				@media screen and (max-width:1199px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-4{display:none}
				}
				@media screen and (max-width:972px){
					nav.main-nav ul.nav-menu-items .nav-5{display:none}
				}
				@media screen and (max-width:1087px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-5{display:none}
				}
				@media screen and (max-width:860px){
					nav.main-nav ul.nav-menu-items .nav-6{display:none}
				}
				@media screen and (max-width:975px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-6{display:none}
				}
				@media screen and (max-width:748px){
					nav.main-nav ul.nav-menu-items .nav-7{display:none}
				}
				@media screen and (max-width:863px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-7{display:none}
				}
				@media screen and (max-width:636px){
					nav.main-nav ul.nav-menu-items .nav-8{display:none}
				}
				@media screen and (max-width:751px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-8{display:none}
				}
				
</style>
<link rel='stylesheet' id='child-theme-css-css'  href='https://metrophiladelphia.com/wp-content/themes/schnepstheme-philly/build/main.dbf1a46c061a339bdc53.css' type='text/css' media='all' />
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/plugins/schneps-rest-post-pusher/public/js/schneps-rest-post-pusher-public.js?ver=2.1.1' id='schneps-rest-post-pusher-js'></script>
<script type='text/javascript' id='read-more.js-js-extra'>
/* <![CDATA[ */
var pp_vars = {"publisher_id":"76dd5de7-67e8-44ed-a248-ec77daf8930e","widget_endpoint":"https:\/\/gadget.pico.tools","plugin_version":"1.0.1","widget_version":"11.29.21.21.59","pico_context":"gadget","post_id":"60550","post_type":"post","post_title":"Motivation fuels the action in Dolph Lundgren's 'Castle Falls'","taxonomies_for_this_post_type":["category","post_tag","post_format","flags","districts","post_status","ef_editorial_meta","following_users","ef_usergroup","author"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","wp_theme","flags","districts","post_status","ef_editorial_meta","following_users","ef_usergroup","author"],"show_read_more_button":"1","taxonomies":{"category":["entertainment","movies"],"post_tag":["entertainment","movies"],"following_users":["jack tomczuk","molly given"],"author":["molly given"]},"resource_ref":"name=motivation-fuels-the-action-in-dolph-lundgrens-castle-falls"};
/* ]]> */
</script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/plugins/pico/includes/js/read-more.js?ver=11.29.21.21.59' id='read-more.js-js'></script>
<link rel="https://api.w.org/" href="https://metrophiladelphia.com/wp-json/" /><link rel="alternate" type="application/json" href="https://metrophiladelphia.com/wp-json/wp/v2/posts/60550" /><link rel="alternate" type="application/json+oembed" href="https://metrophiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmetrophiladelphia.com%2Fmotivation-fuels-the-action-in-dolph-lundgrens-castle-falls%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://metrophiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmetrophiladelphia.com%2Fmotivation-fuels-the-action-in-dolph-lundgrens-castle-falls%2F&#038;format=xml" />
<link rel="preconnect" href="https://fonts.googleapis.com/" crossorigin>
<link rel="dns-prefetch" href="https://fonts.googleapis.com/">
<link rel="preconnect" href="https://cdnjs.cloudflare.com/" crossorigin>
<link rel="dns-prefetch" href="https://cdnjs.cloudflare.com/">
<link rel="shortcut icon" href="https://metrophiladelphia.com/wp-content/uploads/2021/11/favicon.png"><link rel="apple-touch-icon-precomposed" href="https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png">	
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-53524189-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-53524189-3');
</script>

<script>var clicky_site_ids = clicky_site_ids || []; clicky_site_ids.push(101243450);</script>
<script async src="//static.getclicky.com/js"></script>


<meta name="theme-color" content="#0f6855">
 

<!--Centro pixel-->
<script src ="https://cdn01.basis.net/assets/up.js?um=1"></script>
<script type="text/javascript">
	cntrUpTag.track('cntrData', '196232ce72840eca');
</script><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var REFRESH_KEY = 'refresh';
    var REFRESH_VALUE = 'true';   
    //desktop ROS 
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_1', [300, 250], 'div-gpt-ad-1570802487184-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_2', [300, 250], 'div-gpt-ad-1570821891441-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_3', [300, 250], 'div-gpt-ad-1570821979731-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_4', [300, 250], 'div-gpt-ad-1570823235622-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_5', [300, 250], 'div-gpt-ad-1570823235622-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_1', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_2', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_3', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-2').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_tower_1', [[300, 600], [300, 250]], 'div-gpt-ad-1571013535193-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_tower_2', [[300, 600], [300, 250]], 'div-gpt-ad-1571013535193-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    
    googletag.defineSlot('/1048906/metro_philly_ros_pixel_1x1', [1, 1], 'div-gpt-ad-1570992069741-0').addService(googletag.pubads());
    
    //mobile ROS
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_1', [300, 250], 'div-gpt-ad-1571013590977-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_2', [300, 250], 'div-gpt-ad-1571013590977-2').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_3', [300, 250], 'div-gpt-ad-1571013590977-3').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_4', [300, 250], 'div-gpt-ad-1571013590977-4').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_5', [300, 250], 'div-gpt-ad-1571013590977-5').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_leader', [320, 50], 'div-gpt-ad-1571013707377-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
  
    //keyword targeting
    googletag.pubads().setTargeting("SCKeyword", ["entertainment","movies","entertainment","entertainment","movies","post-60550"] );

    //Refresh Check 
    var SECONDS_TO_WAIT_AFTER_VIEWABILITY = 60;
     googletag.pubads().addEventListener('impressionViewable', function(event) {
     var slot = event.slot;
     if (slot.getTargeting(REFRESH_KEY).indexOf(REFRESH_VALUE) > -1) {
     setTimeout(function() {
        googletag.pubads().refresh([slot]);
       //console.log("fresh ads");
       }, SECONDS_TO_WAIT_AFTER_VIEWABILITY * 1000);
     }
    });

	googletag.pubads().collapseEmptyDivs(true);    
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6749561928889346",
          enable_page_level_ads: true
     });
</script>
</head>

<body class="post-template-default single single-post postid-60550 single-format-standard singular theme-child-schnepstheme-philly motivation-fuels-the-action-in-dolph-lundgrens-castle-falls">
			 
		<script 
			async 
			src="https://launcher.spot.im/spot/sp_37Vm0WQ5"
			data-spotim-module="spotim-launcher"
			data-post-url="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/"
			data-article-tags="Entertainment"    
			data-post-id="60550"
			data-spotim-autorun="false">
		</script>
			
	
	<div id="grid-wrapper" class="PicoSignal">
	
	<div class="ad-container header-ad-container">
<!-- /1048906/metro_philly_desktop_ros_leader_1 -->
<div id='div-gpt-ad-1570823321511-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823321511-0'); });
  </script>
</div>
</div>
			
	<div class="potential-overlay-container standard-header-container">
		<div class="potential-overlay standard-header">
			<div class="header-wrapper">
<header class="header-standard site-masthead">
     <div class="magazines-container">
    <a href="/category/digital-editions">
        <span class="the-cover"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/metro-philadelphia-november-29-2021-551x700.jpg" width="400" height="475" alt="Newspaper cover"></span>
        <h4>Flip through <br> today’s papers</h4>
    </a>
</div>
   
    <div class="logo-container">
		<a href="/"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/MetroGreen.png" alt="Metro Philadelphia" class="fullLogo" width="2209" height="955"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/metro-logo-white-centered.png" alt="" class="scrolldownLogo" width="2298" height="736"></a>    </div>
    
    <div class="subscribe-container HideWhenRegistered">
    <h4>Metro Newsletter</h4>
    <p>Tackle the city, with our help.</p>
    <a class="PicoRule basic-button bkg-plain">Subscribe</a>
</div>
<div class="subscribe-container manage-container ShowWhenRegistered">
    <h4>Metro Newsletter</h4>
    <p>Manage your settings.</p>
    <a class="PicoManageAccount basic-button bkg-plain">Manage</a>
</div>
        <div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
    </div>
</header>
</div>

	<div class="nav-container">

<!-- Navigation - Singlerow -->
<!-- loop through menu row -->

<nav class="main-nav static-menu" role="navigation">
	<ul class="nav-menu-items">
				
		<li class="nav-menu-item nav-menu-item-basic nav-jobs nav-10">
			  <a class="nav-menu-link" href="https://jobs.metrophiladelphia.com/" target="_blank"><i class="fas fa-user-tie"></i>Jobs</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-best-of nav-9">
			  <a class="nav-menu-link" href="https://bestof.metro.us/" target="_blank">Best of</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-news nav-8 nav-menu-item-with-submenu menu-opener navigable">
			  <a class="nav-menu-link" href="/category/news/">News</a>
			  				    
				  <ul class="dropdown">
				  					  <li><a href="/">All</a></li>
				  					  <li><a href="/category/sports/">Sports</a></li>
				  					  <li><a href="/category/entertainment/">Entertainment</a></li>
				  					  <li><a href="/category/things-to-do/">Things to Do</a></li>
				  					  <li><a href="/category/lifestyle/">Lifestyle</a></li>
				  					  <li><a href="/category/crime/">Crime</a></li>
				    
				  				  </ul>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-things-to-do nav-7 nav-menu-item-with-submenu menu-opener navigable">
			  <a class="nav-menu-link" href="/category/things-to-do/">Things to Do</a>
			  				    
				  <ul class="dropdown">
				  					  <li><a href="/category/things-to-do/">Things to Do</a></li>
				  					  <li><a href="https://www.schnepsmedia.com/upcoming-events/">Business Events</a></li>
				  					  <li><a href="https://games.metro.us/?arkpromo=Site_TopNav">Games</a></li>
				    
				  				  </ul>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-contact-us nav-6">
			  <a class="nav-menu-link" href="/contact-us/">Contact Us</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-digital-editions nav-5">
			  <a class="nav-menu-link" href="/category/digital-editions/">Digital Editions</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-subscriptions nav-4">
			  <a class="nav-menu-link" href="https://simplecirc.com/subscribe/philadelphia-metro" target="_blank">Subscriptions</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-webinars nav-3">
			  <a class="nav-menu-link" href="https://www.schnepsmedia.com/webinars/" target="_blank">Webinars</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-podcasts nav-2">
			  <a class="nav-menu-link" href="https://podcasts.schnepsmedia.com" target="_blank">Podcasts</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-metrobet nav-1">
			  <a class="nav-menu-link" href="https://www.metro.us/sports/bet" target="_blank">MetroBet</a>
			                  
		  </li>
	  	  
		
    </ul>
</nav>

	<nav class="corner-nav" role="navigation">
	
			<div class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank">
				<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank">
				<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank">
				<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</div>
		<div class="nav-menu-search-newsletter nav-menu-icon-row"><a class="nav-menu-contact" href="/contact-us/"><i class="fas fa-envelope-open-text" aria-hidden="true" aria-label="Contact Us"></i></a>

</div>
	
			<div class="nav-menu-search-box bkg-main">
<form role="search" method="get" class="search-form" action="/">
<label>
	<span class="screen-reader-text">Search:</span>
	<input type="search" class="search-field" placeholder="Search" value="" name="s">
</label>
<button type="submit" class="basic-button bkg-main search-submit icon-search-basic" value="Search"><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></button>
</form>		</div>
        <div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
    </div>    
    </nav>


	</div>

<!--<div class="overlay-magazine-container">
</div>--> 
		</div>
	</div>
	<div class="potential-overlay-container actual-overlay-container">
		<div class="potential-overlay actual-overlay">
		</div>
	</div>

	 
<div class="content-container single-template transparent-container wallpaper-container">
<div class="container-center-cut">
	 

    <div class="content-section standard-singlepost">

        <div class="content-main">
        		            <article id="post-60550" class="post-60550 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-movies tag-entertainment tag-movies">
                <div class="article-header">
                    
                    			<div class="category-box category-label category-label-entertainment">
			<a href="https://metrophiladelphia.com/category/entertainment/">Entertainment</a>
			</div>
		                    
                    <h1 class="article-title">Motivation fuels the action in Dolph Lundgren&#8217;s &#8216;Castle Falls&#8217;</h1>
                    
                                            <div class="article-meta triple">
                            
							<span class="byline"><img alt='' src='https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png' srcset='https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/><span class="name">By <a href="https://metrophiladelphia.com/author/molly-given/" title="Posts by Molly Given" class="author url fn" rel="author">Molly Given</a></span></span>
														    <div class="comments-meta spotim-commentscount"><a href="#comments-anchor"><i class="far fa-comment-alt"></i> <div class="spot-im-replies-count" data-post-id="60550" real-time="true">0</div> comments</a></div>
							
							<span class="posted-on">Posted on <a href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/" rel="bookmark"><time class="entry-date published updated" datetime="2021-11-29T13:50:22-05:00">November 29, 2021</time></a></span>                            
                        </div><!-- .article-meta -->
                                        </div><!-- .article-header -->

                <!--<div class="post-thumbnail" style="max-width: 2560px;">-->
<div class="post-thumbnail">
	<div class="image-wrapper">
				
				<img width="1200" height="675" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1200x675.jpg" class="crop-center wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1200x675.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-700x394.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-768x432.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1536x864.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-2048x1152.jpg 2048w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-384x216.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-900x506.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1600x900.jpg 1600w" sizes="(max-width: 1200px) 100vw, 1200px" />			</div>
	<div class="image-caption">Dolph Lundgren</div>	<div class="image-credit">Courtesy of Shout! Studios</div></div><!-- .post-thumbnail -->

                <div class="addthis_inline_share_toolbox"></div>

                <div class="article-content">
                    <p class="promo-oneliner newsletter"><span><i class="far fa-envelope" aria-hidden="true"></i></span> <span>Sign up for <a class="PicoRule" href="#">our Daily Email newsletter</a> to stay up-to-date on the latest local news throughout Philadelphia.</span></p><div class="at-above-post addthis_tool" data-url="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/"></div><div id="pico"><p>Dolph Lundgren, Scott Adkins and a crew of desperate characters are all on the hunt for stolen money inside a building timed for destruction in the latest action-packed feature, &#8220;Castle Falls.&#8221; Directed by Lundgren, the story centers on people who are in desperate situations and audiences get to see firsthand what they will do for money.</p>
<p>But the action, the fight scenes, the stunts and even the explosions wouldn&#8217;t make a difference if there weren&#8217;t reasons behind the greed and motivations behind the journey. To help build that, Lundgren worked on the script and his own character (Richard Ericson) to make this movie feel high stakes, even with a low-budget 17-day shoot during COVID. And it&#8217;s the transformation that the main character  (Adkins&#8217; Mike Wade) realizes that drives it all home: It isn&#8217;t all about what you do for yourself, it&#8217;s also what you do for others that&#8217;s important in life. Even in an action film.</p><div class="syndicated-embedded-player">
	<div class="meta-box podcast-meta-box">

		<a class="logo" href="https://podcasts.schnepsmedia.com/podcast/schneps-connects/"><img width="160" height="160" src="https://podcasts.schnepsmedia.com/wp-content/uploads/2020/10/Josh-Headshot-Zoom_20202110_2000x2000px_qns_av-1-384x384.jpg" class="crop-center attachment-160x160 size-160x160" alt="" loading="lazy" /></a>
	
		<div class="metadata podcast-metadata">
			<h3 class="meta-name episode-title"><a href="https://podcasts.schnepsmedia.com/2021/10/14/city-winery-michael-dorf/">The <span class="lgwd">Entrepreneur</span> Behind City Winery with Michael Dorf, Founder <span class="titend">and CEO</span></a></h3>
			<h4 class="meta-name podcast-name"><a href="https://podcasts.schnepsmedia.com/podcast/schneps-connects/">Schneps Connects</a></h4>
			
									<div class="audio-listen-box">
				<!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->
<audio class="wp-audio-shortcode" id="audio-60550-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://podcasts.schnepsmedia.com/wp-content/uploads/2021/10/City-Winery.mp3?_=1" /><a href="https://podcasts.schnepsmedia.com/wp-content/uploads/2021/10/City-Winery.mp3">https://podcasts.schnepsmedia.com/wp-content/uploads/2021/10/City-Winery.mp3</a></audio>			</div><!--/audio-listen-box-->
						
			
		</div><!--/podcast-metadata-->
	
	</div><!--/podcast-meta-box-->

	<div class="meta-box podcast-subscribe">
	
<ul class="meta-links podcast-links">
	<li class="subscribe-links-hed"><h5 class="subscribe-title">Subscribe:</h5></li>
						<li class="subscribe-links"><a target="_blank" href="https://podcasts.schnepsmedia.com/podcast/schneps-connects/feed/"><i class="fas fa-rss"></i><span class="link-name">RSS</span></a></li>
								<li class="subscribe-links"><a target="_blank" href="https://podcasts.apple.com/us/podcast/schneps-connects/id1537870221"><i class="fab fa-apple"></i><span class="link-name">iTunes</span></a></li>
								<li class="subscribe-links"><a target="_blank" href="https://open.spotify.com/show/6SjZV6vYUxE1TTog7OeMqG?si=pJhCe9IrTpacfziq3RB1PQ"><i class="fab fa-spotify"></i><span class="link-name">Spotify</span></a></li>
								<li class="subscribe-links"><a target="_blank" href="https://www.stitcher.com/podcast/brooklyn-paper/schneps-connects"><i class="fas fa-microphone"></i><span class="link-name">Stitcher</span></a></li>
								<li class="subscribe-links"><a target="_blank" href="https://music.amazon.com/podcasts/0e617695-98d7-4d2e-9acd-935d789e98bb/schneps-connects"><i class="fab fa-amazon"></i><span class="link-name">Amazon</span></a></li>
								<li class="subscribe-links"><a target="_blank" href="https://podcasts.google.com/feed/aHR0cHM6Ly9wb2RjYXN0cy5zY2huZXBzbWVkaWEuY29tL3BvZGNhc3Qvc2NobmVwcy1jb25uZWN0cy9mZWVkLw"><i class="fab fa-google"></i><span class="link-name">Google Play</span></a></li>
					
</ul>
	</div>
	
</div><!--/syndicated-embedded-player-->


<p>Lundgren sat down to talk more about what went into making &#8220;Castle Falls.&#8221;</p>
<figure id="attachment_60559" aria-describedby="caption-attachment-60559" style="max-width: 700px" class="wp-caption alignnone"><img loading="lazy" class="size-medium wp-image-60559" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-700x394.jpg" alt="" width="700" height="394" srcset="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-700x394.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-1200x675.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-768x432.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-1536x864.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-384x216.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-900x506.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL6-1600x900.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption id="caption-attachment-60559" class="wp-caption-text"><span class="image-caption">Dolph Lundgren and Scott Adkins</span><span class="image-credit">Courtesy of Shout! Studios</span></figcaption></figure>
<p><strong>What was it about this story that made you want to sign on to direct and act?</strong></p>
<p>I had a project with Scott Adkins that fell through so I was looking for a two-hander. I read the script, it&#8217;s sort of what it is now but there weren&#8217;t really two leads. I had to develop [my character] a little more and give both of these people a backstory that was more human and a little more down to earth. Then, I liked the fact that it was unity of a time and a place and that it was [mainly] one building. It was a ticking clock, 90 minutes in the movie, and towards the end it&#8217;s real time&#8230; I liked all of those factors that made it possible to make the film in 17 days. It was quite difficult [during COVID], but those story points made it easier.</p>
<p><strong>What can you tell me about your character?</strong></p>
<p>I wanted to give my character some hard decisions to make. Look, you&#8217;re law enforcement and now your daughter is sick and you kind of have to get your hands in some dirty money&#8230; you&#8217;re not really hurting anyone from stealing it, but you&#8217;re still stealing it and you could end up going to the same jail you&#8217;re working at. I wanted to find stuff that made it interesting for me as an actor as well. Scott&#8217;s the lead, and his character goes through the transformation, whereas my character is just desperate.</p>
<p><strong>Does having acting experience help you as a director?</strong></p>
<p>I needed all the experience I had on this picture to be able to get stunts done and to get the dramatic scenes shot and to not overshoot or waste time on it and still get the performance. It was a tough shoot during COVID. On a script level, you think some things work, but you don&#8217;t have time to figure it out when you&#8217;re shooting, you just shoot it. So with post, I had to hatch a bunch of things together that weren&#8217;t working to tweak the story and keep the pacing going, things like that.</p>
<p><strong>What about stunts and fighting scenes, what goes into working on those sequences specifically? </strong></p>
<p>The reason I got Scott Adkins and the reason it worked — he&#8217;s played an MMA fighter. Story point wise, he is able to fight and throw kicks and punches and knees, so you don&#8217;t have to stretch the imagination too much. Also, he&#8217;s a very good fighter and he can do long, 30-second takes and he won&#8217;t mess it up. We have the choreographer he works with from Europe, but he couldn&#8217;t make it to America because of COVID, but he would design the fights and Scott would rehearse. Then we had a very good operator — another stunt guy — who works in the Marvel movies and he can anticipate everything. We were lucky [with] Scott&#8217;s skills and because we hired people who could fight.</p>
<p><strong>You mentioned earlier developing more back stories for the characters, why is that important to you?</strong></p>
<p>My taste in movies are some of Clint Eastwood&#8217;s pictures that are entertaining and fun, but, they are serious and there is depth to them and the characters are real people. Whether it&#8217;s &#8220;Gran Torino&#8221; or &#8220;Unforgiven,&#8221; he&#8217;s very good at doing that. The more you build a backstory, whether it&#8217;s in the script or as a director, the more layered the performance becomes. When you show up on set with your cameras, if you don&#8217;t really own it, then you try to make something happen&#8230; but if you don&#8217;t really have work on it for a few months then you don&#8217;t really have to try so hard, it makes it easier for the directors and actors. I like to write backstories for all the main characters and then the actors can change them. Somebody said: In real life nothing is general, you&#8217;re very specific&#8230; only actors are general. That&#8217;s why I like the backstories, I think it&#8217;s very important.</p>
<figure id="attachment_60560" aria-describedby="caption-attachment-60560" style="max-width: 700px" class="wp-caption alignnone"><img loading="lazy" class="size-medium wp-image-60560" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-700x394.jpg" alt="" width="700" height="394" srcset="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-700x394.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-1200x675.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-768x432.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-1536x864.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-384x216.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-900x506.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL8-1600x900.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption id="caption-attachment-60560" class="wp-caption-text"><span class="image-caption">Adkins</span><span class="image-credit">Courtesy of Shout! Studios</span></figcaption></figure>
<p><strong>That makes sense and the first character that comes to mind with that idea is Drago. We see more of him in &#8220;Creed&#8221; and you understand his backstory even more. </strong></p>
<p>You know even when I played the first movie as a kid, I was lucky I had this Russian director who was my dialogue coach, he also helped me with my performance. He helped me work on the fact that this guy has been training since he was a kid. He had nothing to say, the Soviet union picked him and he had nothing to say about it. Some of the things that Drago did like kill Apollo — he didn&#8217;t really want to do it. So, you get a subtle feeling he&#8217;s not the driving force&#8230; he&#8217;s Frankenstein&#8217;s monster. That&#8217;s why that character started out playing as a bad guy, but then you see. In real life you try to figure out what somebody&#8217;s about, [whereas] on film it&#8217;s what you&#8217;re thinking and saying.</p>
<p><em>&#8220;Castle Falls&#8221; will be available in theaters, on demand and digital Dec. 3</em></p>
<p>&nbsp;</p>
</div><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/"></div><!-- AddThis Share Buttons generic via filter on the_content -->
                    
                </div><!-- .article-content -->

                <div class="article-footer">

                    
                    <div class="addthis_inline_share_toolbox"></div>

                    
                    <div class="author-meta">
                        	<h3 class="about-the-author">About the Author</h3>
 
                    </div>

                    						<div class="comments-container">
                            <div data-spotim-module="conversation" data-post-id="60550"></div>
						</div>
										
					
                    					
                </div><!-- .article-footer-->
            </article>

		        </div>
		<div class="sidebar-section widget-area">
            <section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_1 -->
<div id='div-gpt-ad-1570802487184-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570802487184-0'); });
  </script>
</div>
</div>
</section>
<section class="featured_jobs_widget widget">
<div class="top-posts featured featured-jobs">
<h2 class="widget-title"><a href="https://jobs.metrophiladelphia.com" target="_blank">Featured Jobs</a></h2>
<h4 class="widget-add-yours"><a href="https://jobs.metrophiladelphia.com/list-your-job/" target="_blank" class="basic-button bkg-main"><i class="fas fa-user-plus"></i>Add your job</a></h4>
<ul class="display-posts-listing">
<li class="listing-item article-container cards-design"><span class="title-wrapper"><a class="title" href="https://jobs.metrophiladelphia.com/2021/11/16/sales-executive/" target="_blank"><span class="company-name"><i class="fas fa-building"></i>Metro Philadelphia</span><span class="job-title">Sales Executive</span></a></span>
</li>
		</ul>
<h4 class="widget-add-yours"><a href="https://jobs.metrophiladelphia.com" class="basic-button bkg-main" target="_blank">View all jobs…</a></h4>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_2 -->
<div id='div-gpt-ad-1570821891441-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570821891441-0'); });
  </script>
</div>
</div>
</section><section class="widget_promo widget optional"><div class="top-posts news">
<h2 class="widget-title">News</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/who-flags-omicron-risk-travel-curbs-tighten-biden-urges-vaccination/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-29T063422Z_1_LYNXMPEHAS07L_RTROPTP_4_HEALTH-CORONAVIRUS-AUSTRALIA-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/who-flags-omicron-risk-travel-curbs-tighten-biden-urges-vaccination/">WHO flags Omicron risk, travel curbs tighten, Biden urges <span class="lgwd">vaccination</span></a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/teen-killed-in-north-philly-shooting/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/08/DSC_0279-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/teen-killed-in-north-philly-shooting/">Two teens killed in North Philly shootings</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/twitter-ceo-jack-dorsey-hands-reins-to-technology-chief-agrawal/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-29T182711Z_2_LYNXMPEHAS10O_RTROPTP_4_FRANCE-TECH-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/twitter-ceo-jack-dorsey-hands-reins-to-technology-chief-agrawal/">Twitter CEO Jack Dorsey hands reins to technology chief Agrawal</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/eu-russia-iran-upbeat-as-nuclear-talks-resume-amid-skepticism/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-29T190835Z_1_LYNXMPEHAS12W_RTROPTP_4_IRAN-NUCLEAR-TALKS-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/eu-russia-iran-upbeat-as-nuclear-talks-resume-amid-skepticism/">EU, Russia, Iran upbeat as nuclear talks resume amid skepticism</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/castro-vows-to-pull-honduras-out-of-the-abyss-as-first-female-president/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-29T161844Z_1_LYNXMPEHAS0UP_RTROPTP_4_HONDURAS-ELECTION-CASTRO-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/castro-vows-to-pull-honduras-out-of-the-abyss-as-first-female-president/">Castro vows to pull Honduras &#8216;out of the abyss&#8217; as first female president</a></span></li></ul>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_3 -->
<div id='div-gpt-ad-1570821979731-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570821979731-0'); });
  </script>
</div>
</div>
</section><section class="widget_promo widget optional"><div class="top-posts arts">
<h2 class="widget-title">Entertainment</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/sisterly-love-food-fair-celebrates-on-year-with-series-of-holiday-markets/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/202934476_332988051677977_3047311026494367776_n-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/sisterly-love-food-fair-celebrates-on-year-with-series-of-holiday-markets/">Sisterly Love Food Fair celebrates on year with series of holiday markets</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/bts-emotional-beyond-words-to-play-in-front-of-fans-again/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-29T094542Z_1_LYNXMPEHAS0DN_RTROPTP_4_MUSIC-BTS-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/bts-emotional-beyond-words-to-play-in-front-of-fans-again/">BTS &#8217;emotional beyond words&#8217; to play in front of fans again</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/">Motivation fuels the action in Dolph Lundgren&#8217;s &#8216;Castle Falls&#8217;</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/phillys-disco-biscuits-drop-nfts-and-prep-for-new-years-shows/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/DISCO-BISCUITS-PRESS-PHOTO-DAVE-VANN-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/phillys-disco-biscuits-drop-nfts-and-prep-for-new-years-shows/">Philly’s Disco Biscuits drop NFTs and prep for New Year&#8217;s shows</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/juana-tamales-adds-bold-flavors-to-the-community-and-not-just-through-the-food/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/unnamed-3-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/juana-tamales-adds-bold-flavors-to-the-community-and-not-just-through-the-food/">Juana Tamales adds bold flavors to the community — and not just through the food</a></span></li></ul>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_4 -->
<div id='div-gpt-ad-1570823235622-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823235622-0'); });
  </script>
</div>
</div>
</section>
<section class="widget_promo widget optional"><div class="top-posts sports">
<h2 class="widget-title">Sports</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/phillies-will-see-plenty-more-of-max-scherzer-after-mets-blockbuster/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/10/2021-10-07T004248Z_736315243_MT1USATODAY16902813_RTRMADP_3_MLB-WILDCARD-ST-LOUIS-CARDINALS-AT-LOS-ANGELES-DODGERS-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Max Scherzer Dodgers" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/phillies-will-see-plenty-more-of-max-scherzer-after-mets-blockbuster/">Phillies will see plenty more of Max Scherzer after Mets <span class="lgwd">blockbuster</span></a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/its-on-me-eagles-jalen-hurts-takes-responsibility-for-giants-loss/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-28T181545Z_171374754_MT1USATODAY17248961_RTRMADP_3_NFL-PHILADELPHIA-EAGLES-AT-NEW-YORK-GIANTS-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Jalen Hurts Eagles" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/its-on-me-eagles-jalen-hurts-takes-responsibility-for-giants-loss/">&#8216;It&#8217;s on me&#8217;: Eagles&#8217; Jalen Hurts takes <span class="lgwd">responsibility</span> for Giants loss</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/phillies-have-had-talks-with-nick-castellanos-report/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-09-15T020326Z_1940024163_MT1USATODAY16752922_RTRMADP_3_MLB-CINCINNATI-REDS-AT-PITTSBURGH-PIRATES-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Nick Castellanos Phillies rumors" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/phillies-have-had-talks-with-nick-castellanos-report/">Phillies have had talks with Nick <span class="lgwd">Castellanos:</span> report</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/flyers-game-tuesday-postponed-due-to-islanders-covid-outbreak/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2020/10/sptp_wells_fargo_center_1006-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Wells Fargo Center" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/flyers-game-tuesday-postponed-due-to-islanders-covid-outbreak/">Flyers game Tuesday postponed due to Islanders COVID outbreak</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/hurts-eagles-cant-figure-out-giants-in-upset-loss/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-28T193701Z_1326626847_MT1USATODAY17249449_RTRMADP_3_NFL-PHILADELPHIA-EAGLES-AT-NEW-YORK-GIANTS-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Giants Eagles Darnay Holmes" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/hurts-eagles-cant-figure-out-giants-in-upset-loss/">Hurts, Eagles can&#8217;t figure out Giants in upset loss</a></span></li></ul>
</div></section>        </div>
    </div><!-- #main -->

	 
</div>
</div><!-- #primary -->

<div class="ad-container content-ad-container">
<!-- /1048906/metro_philly_desktop_ros_leader_2 -->
<div id='div-gpt-ad-1570823321511-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823321511-1'); });
  </script>
</div>
</div> 

	<div class="popularcommunity-container">
		<div data-spotim-module="pitc"></div>
	</div>
<div class="related-posts-footer">
<h2 class="related-title">Related Articles</h2>
	<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/"><img width="700" height="394" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-700x394.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-700x394.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1200x675.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-768x432.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1536x864.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-384x216.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-900x506.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2021/11/CASTLEFALLS_STILL1-1600x900.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/motivation-fuels-the-action-in-dolph-lundgrens-castle-falls/">Motivation fuels the action in Dolph Lundgren&#8217;s &#8216;Castle Falls&#8217;</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/american-murder-the-family-next-door-paints-a-haunting-picture/"><img width="700" height="467" src="https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-700x467.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/10/S4738_NARRATIVE_PHOTO_XXXX_D61A0033_PROFESSIONAL_IMAGES_OF_THE_WATTS_FAMILY_26_11_2017-900x600.jpg 900w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/american-murder-the-family-next-door-paints-a-haunting-picture/">&#8216;American Murder: The Family Next Door&#8217; paints a haunting picture</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/gabourey-sidibe-on-why-antebellum-will-move-the-world-forward/"><img width="700" height="467" src="https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-700x467.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/09/antebellum-A_D24_06746_R_rgb-900x600.jpg 900w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/gabourey-sidibe-on-why-antebellum-will-move-the-world-forward/">Gabourey Sidibe on why &#8216;Antebellum&#8217; will &#8216;move the world forward&#8217;</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/blackbird-although-about-death-still-teaches-about-life/"><img width="700" height="291" src="https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-700x291.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-700x291.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-1200x499.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-768x320.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-1536x639.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-384x160.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/09/BLACKBIRD_TIFF-STILL_R-900x374.jpg 900w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/blackbird-although-about-death-still-teaches-about-life/">&#8216;Blackbird&#8217;, although about death still teaches about life</a></span></li></ul></div> 

<div class="hero-container sister-sites-container component-container card" style="background: #000e0a">

	<div class="component-title-section">
		<h2 class="section-title">More from our Sister Sites</h2>
	</div>

    <div class="hero-section sister-sites component-content-section hero-blocks-4">
    				<article class="article-container cards-design">
					<a href="https://www.caribbeanlife.com/jamaican-women-score-three-grammy-nod-for-the-first-time/"><img width="700" height="691" src="https://www.caribbeanlife.com/wp-content/uploads/2019/06/2019-06-21-nk-dancehall-queen-spice-awards-cl01_z-700x691.jpg" class="crop-top wp-post-image" alt="" loading="lazy" srcset="https://www.caribbeanlife.com/wp-content/uploads/2019/06/2019-06-21-nk-dancehall-queen-spice-awards-cl01_z-700x691.jpg 700w, https://www.caribbeanlife.com/wp-content/uploads/2019/06/2019-06-21-nk-dancehall-queen-spice-awards-cl01_z-768x758.jpg 768w, https://www.caribbeanlife.com/wp-content/uploads/2019/06/2019-06-21-nk-dancehall-queen-spice-awards-cl01_z.jpg 1184w" sizes="(max-width: 700px) 100vw, 700px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-caribbean-life"><a href="https://caribbeanlifenews.com">Caribbean Life</a></div>
				<h2><a href="https://www.caribbeanlife.com/jamaican-women-score-three-grammy-nod-for-the-first-time/">Jamaican women score three Grammy nods for the <span class="titend">first time</span></a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://www.amny.com/news/ag-james-leads-coalition-defending-rights-of-transgender-students/"><img width="700" height="467" src="https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-700x467.jpeg" class="crop-center wp-post-image" alt="" loading="lazy" srcset="https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-700x467.jpeg 700w, https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-1200x801.jpeg 1200w, https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-768x512.jpeg 768w, https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-1536x1025.jpeg 1536w, https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-384x256.jpeg 384w, https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-900x600.jpeg 900w, https://www.amny.com/wp-content/uploads/2021/08/2021-08-03T155946Z_1_LYNXMPEH720ZW_RTROPTP_4_NEW-YORK-CUOMO-1600x1067.jpeg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-amny"><a href="https://www.amny.com">AMNY</a></div>
				<h2><a href="https://www.amny.com/news/ag-james-leads-coalition-defending-rights-of-transgender-students/">AG James leads coalition defending rights of transgender <span class="titend">students</span></a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://podcasts.schnepsmedia.com/2021/11/28/new-york-citys-status-as-a-melting-pot-is-most-on-display-within-its-caribbean-neighborhoods/"><img width="800" height="533" src="https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-800x533.jpg" class="crop-center no-crop wp-post-image" alt="" loading="lazy" srcset="https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-800x533.jpg 800w, https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-1200x800.jpg 1200w, https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-768x512.jpg 768w, https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-1536x1024.jpg 1536w, https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-384x256.jpg 384w, https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-900x600.jpg 900w, https://podcasts.schnepsmedia.com/wp-content/uploads/2021/11/9_51675520234_o-1600x1067.jpg 1600w" sizes="(max-width: 800px) 100vw, 800px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-schneps-podcasts"><a href="https://podcasts.schnepsmedia.com">Schneps Podcasts</a></div>
				<h2><a href="https://podcasts.schnepsmedia.com/2021/11/28/new-york-citys-status-as-a-melting-pot-is-most-on-display-within-its-caribbean-neighborhoods/">New York City’s Status as a Melting Pot is Most on Display within its Caribbean <span class="lgwd">Neighborhoods</span></a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://www.gaycitynews.com/letitia-james-leads-coalition-of-states-supporting-trans-student-in-florida/"><img width="700" height="548" src="https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized-700x548.jpeg" class="crop-center wp-post-image" alt="" loading="lazy" srcset="https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized-700x548.jpeg 700w, https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized-1200x940.jpeg 1200w, https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized-768x602.jpeg 768w, https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized-384x301.jpeg 384w, https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized-900x705.jpeg 900w, https://www.gaycitynews.com/wp-content/uploads/2021/07/drew_cropped_sized.jpeg 1500w" sizes="(max-width: 700px) 100vw, 700px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-gay-city-news"><a href="https://www.gaycitynews.com">Gay City News</a></div>
				<h2><a href="https://www.gaycitynews.com/letitia-james-leads-coalition-of-states-supporting-trans-student-in-florida/">James Leads Coalition of States Backing Trans Student in Florida <span class="titend">Bathroom Case</span></a></h2>
					</div>
				</article>
				    </div>
</div>


    <footer class="site-footer">

        	<nav class="footer-nav-menu"><ul>
							<li>
			<a class="" href="/newsletter/" target="">
			<span>Newsletter</span>
			</a>
		</li>
							<li>
			<a class="" href="https://www.calameo.com/subscriptions/6610671" target="_blank">
			<span>Digital Editions</span>
			</a>
		</li>
							<li>
			<a class="" href="/contact-us/" target="">
			<span>Contact Us</span>
			</a>
		</li>
							<li>
			<a class="" href="https://www.schnepsevents.com/ " target="">
			<span>Networking Events</span>
			</a>
		</li>
							<li>
			<a class="" href="https://philly.metro.us/advertise" target="">
			<span>Advertise</span>
			</a>
		</li>
		
	
			<li class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank">
				<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank">
				<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank">
				<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</li>
		
	</ul></nav>
 

        	<nav class="site-info"><ul>
													<li class="copyright">
			<a href="https://www.schnepsmedia.com/" target="_blank">
			<span>© 2021 Schneps Media</span>
			</a>
		</li>
													<li class="">
			<a href="/privacy-policy/" target="">
			<span>Privacy Policy</span>
			</a>
		</li>
													<li class="">
			<a href="/terms/" target="">
			<span>Terms of Use</span>
			</a>
		</li>
		</ul></nav>
 

    </footer>
	
</div> <!--#grid-wrappr-->	

<nav id="theStickyNavBar" class="sticky sticky-fa sticky-bottom-bar" role="navigation">
	<ul>
					
				<li class="hamburger">
					<span class="sticky-item">
					<i class="fas fa-bars opener"></i>
					Sections
					</span>
				</li>

											
				<li class="">
					<a class="sticky-item" href="https://www.calameo.com/subscriptions/6610671" target="_blank" title="">
					<i class="far fa-newspaper"></i>					Editions					</a>
				</li>
											
				<li class="">
					<a class="sticky-item" href="/contact-us/" target="" title="">
					<i class="fas fa-phone"></i>					Contact					</a>
				</li>
											
				<li class="">
					<a class="sticky-item" href="https://games.metro.us/?arkpromo=StickyMenu" target="_blank" title="">
					<i class="fas fa-gamepad"></i>					Games					</a>
				</li>
											<li class="PicoManageAccount nav-menu-newsletter">
					<a class="sticky-item" href="/newsletter/" target="" title="">
					<i class="fas fa-envelope"></i>					Manage
					</a>
				</li>
									
				<li class="PicoRule nav-menu-newsletter">
					<a class="sticky-item" href="/newsletter/" target="" title="">
					<i class="fas fa-envelope"></i>					Sign Up					</a>
				</li>
			
			
			</ul>        
</nav> 

<div id='pico-widget-container'></div><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-f5ecca744013cbc75a73ab967a93c239","page_info":{"template":"posts","post_type":""}}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><link rel='stylesheet' id='mediaelement-css'  href='https://metrophiladelphia.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://metrophiladelphia.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.8.2#pubid=ra-5efa2cdec328d553' id='addthis_widget-js'></script>
<script type='text/javascript' id='theme-js-js-extra'>
/* <![CDATA[ */
var ajax_controller = {"ajax_url":"https:\/\/metrophiladelphia.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/themes/schnepstheme/build/bundle.6f75e12f.js' id='theme-js-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/themes/schnepstheme-philly/build/bundle.2b98a983.js' id='child-theme-js-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.8.2' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.8.2' id='wp-mediaelement-js'></script>

<!-- /1048906/metro_philly_ros_pixel_1x1 -->
<div id='div-gpt-ad-1570992069741-0' style='width: 1px; height: 1px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570992069741-0'); });
  </script>
</div>
 

</body>
</html>
