<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: https://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">

	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.13.1/css/all.min.css">
	
	
<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>&#8216;The Dropout&#8217; star Naveen Andrews on playing Sunny Balwani</title>
<meta name="description" content="Andrews plays Balwani opposite Amanda Seyfried in Hulu&#039;s latest limited series, The Dropout which premieres this week on the streaming platform."/>
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#8216;The Dropout&#8217; star Naveen Andrews on playing Sunny Balwani" />
<meta property="og:description" content="Andrews plays Balwani opposite Amanda Seyfried in Hulu&#039;s latest limited series, The Dropout which premieres this week on the streaming platform." />
<meta property="og:url" content="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/" />
<meta property="og:site_name" content="Metro Philadelphia" />
<meta property="article:tag" content="Entertainment" />
<meta property="article:tag" content="Television" />
<meta property="article:section" content="Entertainment" />
<meta property="og:updated_time" content="2022-03-02T17:49:31-05:00" />
<meta property="og:image" content="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1200x800.jpg" />
<meta property="og:image:secure_url" content="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1200x800.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="og:image:alt" content="The Dropout" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-03-02T17:39:07-05:00" />
<meta property="article:modified_time" content="2022-03-02T17:49:31-05:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="&#8216;The Dropout&#8217; star Naveen Andrews on playing Sunny Balwani" />
<meta name="twitter:description" content="Andrews plays Balwani opposite Amanda Seyfried in Hulu&#039;s latest limited series, The Dropout which premieres this week on the streaming platform." />
<meta name="twitter:image" content="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1200x800.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Molly Given" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="5 minutes" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://metrophiladelphia.com/#organization","name":"Metro Philly","url":"https://metrophiladelphia.com","logo":{"@type":"ImageObject","@id":"https://metrophiladelphia.com/#logo","url":"https://philly.metro.us/wp-content/uploads/2021/04/12370901_1190151520998562_8911266993734335932_o.png","caption":"Metro Philly","inLanguage":"en-US","width":"500","height":"180"}},{"@type":"WebSite","@id":"https://metrophiladelphia.com/#website","url":"https://metrophiladelphia.com","name":"Metro Philly","publisher":{"@id":"https://metrophiladelphia.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-scaled.jpg","url":"https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-scaled.jpg","width":"2560","height":"1706","caption":"The Dropout","inLanguage":"en-US"},{"@type":"Person","@id":"https://metrophiladelphia.com/author/molly-given/","name":"Molly Given","url":"https://metrophiladelphia.com/author/molly-given/","image":{"@type":"ImageObject","@id":"https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png","url":"https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png","caption":"Molly Given","inLanguage":"en-US"},"worksFor":{"@id":"https://metrophiladelphia.com/#organization"}},{"@type":"WebPage","@id":"https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/#webpage","url":"https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/","name":"&#039;The Dropout&#039; star Naveen Andrews on playing Sunny Balwani","datePublished":"2022-03-02T17:39:07-05:00","dateModified":"2022-03-02T17:49:31-05:00","author":{"@id":"https://metrophiladelphia.com/author/molly-given/"},"isPartOf":{"@id":"https://metrophiladelphia.com/#website"},"primaryImageOfPage":{"@id":"https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-scaled.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"&#039;The Dropout&#039; star Naveen Andrews on playing Sunny Balwani","keywords":"The Dropout","datePublished":"2022-03-02T17:39:07-05:00","dateModified":"2022-03-02T17:49:31-05:00","author":{"@id":"https://metrophiladelphia.com/author/molly-given/"},"publisher":{"@id":"https://metrophiladelphia.com/#organization"},"description":"Andrews plays Balwani opposite Amanda Seyfried in Hulu&#039;s latest limited series, The Dropout which premieres this week on the streaming platform.","name":"&#039;The Dropout&#039; star Naveen Andrews on playing Sunny Balwani","@id":"https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/#richSnippet","isPartOf":{"@id":"https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/#webpage"},"image":{"@id":"https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-scaled.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel="amphtml" href="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/amp/" /><meta name="generator" content="AMP for WP 1.0.77.29"/><link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/metrophiladelphia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://metrophiladelphia.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='schneps-rest-post-pusher-css'  href='https://metrophiladelphia.com/wp-content/plugins/schneps-rest-post-pusher/public/css/schneps-rest-post-pusher-public.css?ver=2.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='main_stylesheet-css'  href='https://metrophiladelphia.com/wp-content/plugins/spotim-comments/assets/stylesheets/main.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://metrophiladelphia.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='theme-css-css'  href='https://metrophiladelphia.com/wp-content/themes/schnepstheme/build/main.1bf8d7fb331a2638cb5c.css' type='text/css' media='all' />
<style id='theme-css-inline-css' type='text/css'>
header .hamburger{display:flex}@media screen and (max-width:1980px){
					nav.main-nav ul.nav-menu-items .nav-0{display:none}
				}
				@media screen and (max-width:2095px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-0{display:none}
				}
				@media screen and (max-width:1851px){
					nav.main-nav ul.nav-menu-items .nav-1{display:none}
				}
				@media screen and (max-width:1966px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-1{display:none}
				}
				@media screen and (max-width:1722px){
					nav.main-nav ul.nav-menu-items .nav-2{display:none}
				}
				@media screen and (max-width:1837px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-2{display:none}
				}
				@media screen and (max-width:1593px){
					nav.main-nav ul.nav-menu-items .nav-3{display:none}
				}
				@media screen and (max-width:1708px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-3{display:none}
				}
				@media screen and (max-width:1464px){
					nav.main-nav ul.nav-menu-items .nav-4{display:none}
				}
				@media screen and (max-width:1579px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-4{display:none}
				}
				@media screen and (max-width:1335px){
					nav.main-nav ul.nav-menu-items .nav-5{display:none}
				}
				@media screen and (max-width:1450px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-5{display:none}
				}
				@media screen and (max-width:1206px){
					nav.main-nav ul.nav-menu-items .nav-6{display:none}
				}
				@media screen and (max-width:1321px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-6{display:none}
				}
				@media screen and (max-width:1077px){
					nav.main-nav ul.nav-menu-items .nav-7{display:none}
				}
				@media screen and (max-width:1192px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-7{display:none}
				}
				@media screen and (max-width:948px){
					nav.main-nav ul.nav-menu-items .nav-8{display:none}
				}
				@media screen and (max-width:1063px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-8{display:none}
				}
				@media screen and (max-width:819px){
					nav.main-nav ul.nav-menu-items .nav-9{display:none}
				}
				@media screen and (max-width:934px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-9{display:none}
				}
				@media screen and (max-width:690px){
					nav.main-nav ul.nav-menu-items .nav-10{display:none}
				}
				@media screen and (max-width:805px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-10{display:none}
				}
				
</style>
<link rel='stylesheet' id='child-theme-css-css'  href='https://metrophiladelphia.com/wp-content/themes/schnepstheme-philly/build/main.bd8f9200041800b9640e.css' type='text/css' media='all' />
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/plugins/schneps-rest-post-pusher/public/js/schneps-rest-post-pusher-public.js?ver=2.2.3' id='schneps-rest-post-pusher-js'></script>
<script type='text/javascript' id='read-more.js-js-extra'>
/* <![CDATA[ */
var pp_vars = {"publisher_id":"76dd5de7-67e8-44ed-a248-ec77daf8930e","widget_endpoint":"https:\/\/gadget.pico.tools","plugin_version":"1.0.1","widget_version":"03.03.22.21.22","pico_context":"gadget","post_id":"107136","post_type":"post","post_title":"'The Dropout' star Naveen Andrews discusses playing Sunny Balwani","taxonomies_for_this_post_type":["category","post_tag","post_format","flags","districts","post_status","ef_editorial_meta","following_users","ef_usergroup","author"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","wp_theme","sc_tag","flags","districts","post_status","ef_editorial_meta","following_users","ef_usergroup","author"],"show_read_more_button":"1","taxonomies":{"category":["entertainment","television"],"post_tag":["entertainment","television"],"following_users":["molly given"],"author":["molly given"]},"resource_ref":"name=the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani"};
/* ]]> */
</script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/plugins/pico/includes/js/read-more.js?ver=03.03.22.21.22' id='read-more.js-js'></script>
<link rel="https://api.w.org/" href="https://metrophiladelphia.com/wp-json/" /><link rel="alternate" type="application/json" href="https://metrophiladelphia.com/wp-json/wp/v2/posts/107136" /><link rel="alternate" type="application/json+oembed" href="https://metrophiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmetrophiladelphia.com%2Fthe-dropout-star-naveen-andrews-discusses-playing-sunny-balwani%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://metrophiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmetrophiladelphia.com%2Fthe-dropout-star-naveen-andrews-discusses-playing-sunny-balwani%2F&#038;format=xml" />
<link rel="preconnect" href="https://fonts.googleapis.com/" crossorigin>
<link rel="dns-prefetch" href="https://fonts.googleapis.com/">
<link rel="preconnect" href="https://cdnjs.cloudflare.com/" crossorigin>
<link rel="dns-prefetch" href="https://cdnjs.cloudflare.com/">
<link rel="shortcut icon" href="https://metrophiladelphia.com/wp-content/uploads/2021/11/favicon.png"><link rel="apple-touch-icon-precomposed" href="https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png">	
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-53524189-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-53524189-3');
</script>

<script>var clicky_site_ids = clicky_site_ids || []; clicky_site_ids.push(101243450);</script>
<script async src="//static.getclicky.com/js"></script>


<meta name="theme-color" content="#0f6855">
 

<!--Centro pixel-->
<script src ="https://cdn01.basis.net/assets/up.js?um=1"></script>
<script type="text/javascript">
	cntrUpTag.track('cntrData', '196232ce72840eca');
</script><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var REFRESH_KEY = 'refresh';
    var REFRESH_VALUE = 'true';   
    //desktop ROS 
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_1', [300, 250], 'div-gpt-ad-1570802487184-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_2', [300, 250], 'div-gpt-ad-1570821891441-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_3', [300, 250], 'div-gpt-ad-1570821979731-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_4', [300, 250], 'div-gpt-ad-1570823235622-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_5', [300, 250], 'div-gpt-ad-1570823235622-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_1', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_2', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_3', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-2').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_tower_1', [[300, 600], [300, 250]], 'div-gpt-ad-1571013535193-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_tower_2', [[300, 600], [300, 250]], 'div-gpt-ad-1571013535193-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    
    googletag.defineSlot('/1048906/metro_philly_ros_pixel_1x1', [1, 1], 'div-gpt-ad-1570992069741-0').addService(googletag.pubads());
    
    //mobile ROS
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_1', [300, 250], 'div-gpt-ad-1571013590977-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_2', [300, 250], 'div-gpt-ad-1571013590977-2').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_3', [300, 250], 'div-gpt-ad-1571013590977-3').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_4', [300, 250], 'div-gpt-ad-1571013590977-4').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_5', [300, 250], 'div-gpt-ad-1571013590977-5').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_leader', [320, 50], 'div-gpt-ad-1571013707377-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
  
    //keyword targeting
    googletag.pubads().setTargeting("SCKeyword", ["entertainment","television","entertainment","entertainment","television","post-107136"] );

    //Refresh Check 
    var SECONDS_TO_WAIT_AFTER_VIEWABILITY = 60;
     googletag.pubads().addEventListener('impressionViewable', function(event) {
     var slot = event.slot;
     if (slot.getTargeting(REFRESH_KEY).indexOf(REFRESH_VALUE) > -1) {
     setTimeout(function() {
        googletag.pubads().refresh([slot]);
       //console.log("fresh ads");
       }, SECONDS_TO_WAIT_AFTER_VIEWABILITY * 1000);
     }
    });

	googletag.pubads().collapseEmptyDivs(true);    
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6749561928889346",
          enable_page_level_ads: true
     });
</script>
</head>

<body class="post-template-default single single-post postid-107136 single-format-standard singular theme-child-schnepstheme-philly the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani">
			 
		<script 
			async 
			src="https://launcher.spot.im/spot/sp_37Vm0WQ5"
			data-spotim-module="spotim-launcher"
			data-post-url="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/"
			data-article-tags="Entertainment"    
			data-post-id="107136"
			data-spotim-autorun="false">
		</script>
			
	
	<div id="grid-wrapper" class="PicoSignal">
	
	<div class="ad-container header-ad-container">
<!-- /1048906/metro_philly_desktop_ros_leader_1 -->
<div id='div-gpt-ad-1570823321511-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823321511-0'); });
  </script>
</div>
</div>
			
	<div class="potential-overlay-container standard-header-container">
		<div class="potential-overlay standard-header">
			<div class="header-wrapper">
<header class="header-standard site-masthead">
     <div class="magazines-container">
    <a href="/category/digital-editions">
        <span class="the-cover"><img src="https://metrophiladelphia.com/wp-content/uploads/2022/03/metro-philadelphia-march-3-2022-551x700.jpg" width="400" height="475" alt="Newspaper cover"></span>
        <h4 style="z-index: 10;margin-left: -32px;background: rgba(255,255,255,1);padding: 5px 10px 9px;"><i class="fas fa-newspaper"></i>Flip through <br> today’s papers</h4>
    </a>
</div>
   
    <div class="logo-container">
		<a href="/"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/MetroGreen.png" alt="Metro Philadelphia" class="fullLogo" width="2209" height="955"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/metro-logo-white-centered.png" alt="" class="scrolldownLogo" width="2298" height="736"></a>    </div>
    
    <div class="subscribe-container HideWhenRegistered">
    <h4>Metro Newsletter</h4>
    <p>Tackle the city, with our help.</p>
    <a class="PicoRule basic-button bkg-plain">Subscribe</a>
</div>
<div class="subscribe-container manage-container ShowWhenRegistered">
    <h4>Metro Newsletter</h4>
    <p>Manage your settings.</p>
    <a class="PicoManageAccount basic-button bkg-plain">Manage</a>
</div>
        <div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
    </div>
</header>
</div>

	<div class="nav-container">

<!-- Navigation - Singlerow -->
<!-- loop through menu row -->

<nav class="main-nav static-menu" role="navigation">
	<ul class="nav-menu-items">
				
		<li class="nav-menu-item nav-menu-item-basic nav-jobs nav-12">
			  <a class="nav-menu-link" href="https://jobs.metrophiladelphia.com/" target="_blank"><i class="fas fa-user-tie"></i>Jobs</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-best-of nav-11">
			  <a class="nav-menu-link" href="https://bestof.metro.us/" target="_blank">Best of</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-philly-sports-network nav-10">
			  <a class="nav-menu-link" href="https://phillysportsnetwork.com/" target="_blank"><i class="fas fa-baseball-ball"></i>Philly Sports Network</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-news nav-9 nav-menu-item-with-submenu menu-opener navigable">
			  <a class="nav-menu-link" href="/category/news/">News</a>
			  				    
				  <ul class="dropdown">
				  					  <li><a href="/">All</a></li>
				  					  <li><a href="https://phillysportsnetwork.com/">Sports</a></li>
				  					  <li><a href="/category/entertainment/">Entertainment</a></li>
				  					  <li><a href="/category/things-to-do/">Things to Do</a></li>
				  					  <li><a href="/category/lifestyle/">Lifestyle</a></li>
				  					  <li><a href="/category/crime/">Crime</a></li>
				    
				  				  </ul>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-things-to-do nav-8 nav-menu-item-with-submenu menu-opener navigable">
			  <a class="nav-menu-link" href="/category/things-to-do/">Things to Do</a>
			  				    
				  <ul class="dropdown">
				  					  <li><a href="/category/things-to-do/">Things to Do</a></li>
				  					  <li><a href="https://www.schnepsmedia.com/upcoming-events/">Business Events</a></li>
				  					  <li><a href="https://games.metro.us/?arkpromo=Site_TopNav">Games</a></li>
				    
				  				  </ul>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-politics nav-7">
			  <a class="nav-menu-link" href="/category/politics/">Politics</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-contact-us nav-6">
			  <a class="nav-menu-link" href="/contact-us/">Contact Us</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-digital-editions nav-5">
			  <a class="nav-menu-link" href="/category/digital-editions/">Digital Editions</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-subscriptions nav-4">
			  <a class="nav-menu-link" href="https://simplecirc.com/subscribe/philadelphia-metro" target="_blank">Subscriptions</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-webinars nav-3">
			  <a class="nav-menu-link" href="https://www.schnepsmedia.com/webinars/" target="_blank">Webinars</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-podcasts nav-2">
			  <a class="nav-menu-link" href="https://podcasts.schnepsmedia.com" target="_blank">Podcasts</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-menu-item-basic nav-metrobet nav-1">
			  <a class="nav-menu-link" href="https://www.metro.us/sports/bet" target="_blank">MetroBet</a>
			                  
		  </li>
	  	  
		
    </ul>
</nav>

	<nav class="corner-nav" role="navigation">
	
			<div class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank">
				<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank">
				<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank">
				<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</div>
		<div class="nav-menu-search-newsletter nav-menu-icon-row"><a class="nav-menu-contact" href="/contact-us/"><i class="fas fa-envelope-open-text" aria-hidden="true" aria-label="Contact Us"></i></a>

</div>
	
			<div class="nav-menu-search-box bkg-main">
<form role="search" method="get" class="search-form" action="/">
<label>
	<span class="screen-reader-text">Search:</span>
	<input type="search" class="search-field" placeholder="Search" value="" name="s">
</label>
<button type="submit" class="basic-button bkg-main search-submit icon-search-basic" value="Search"><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></button>
</form>		</div>
        <div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
    </div>    
    </nav>


	</div>

<!--<div class="overlay-magazine-container">
</div>--> 
		</div>
	</div>
	<div class="potential-overlay-container actual-overlay-container">
		<div class="potential-overlay actual-overlay">

			<div class="header-wrapper">
<header class="header-standard site-masthead">
   
    <div class="logo-container">
		<a href="/"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/MetroGreen.png" alt="Metro Philadelphia" class="fullLogo" width="2209" height="955"><img src="https://metrophiladelphia.com/wp-content/uploads/2021/11/metro-logo-white-centered.png" alt="" class="scrolldownLogo" width="2298" height="736"></a>    </div>
    
        <div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
    </div>
</header>
</div>
 
			
			<!-- Navigation - Singlerow -->
<!-- loop through menu row -->

<nav class="main-nav hamburger-menu" role="navigation">
	<ul class="nav-menu-items nav-menu-singlet">
		<li class="hamburger-menu-search-box">
<form role="search" method="get" class="search-form" action="/">
<label>
	<span class="screen-reader-text">Search:</span>
	<input type="search" class="search-field" placeholder="Search" value="" name="s">
</label>
<button type="submit" class="basic-button bkg-main search-submit icon-search-basic" value="Search"><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></button>
</form>		</li>
    </ul>
    
    <div class="hamburger-grid">

	<ul class="nav-menu-items nav-menu-pile">
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="/category/news/">News</a>
			</li><li class="nav-menu-item"><a href="/">All</a></li><li class="nav-menu-item"><a href="https://phillysportsnetwork.com/">Sports</a></li><li class="nav-menu-item"><a href="/category/entertainment/">Entertainment</a></li><li class="nav-menu-item"><a href="/category/things-to-do/">Things to Do</a></li><li class="nav-menu-item"><a href="/category/lifestyle/">Lifestyle</a></li><li class="nav-menu-item"><a href="/category/crime/">Crime</a></li></ul><ul class="nav-menu-items nav-menu-pile">
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="/category/things-to-do/">Things to Do</a>
			</li><li class="nav-menu-item"><a href="/category/things-to-do/">Things to Do</a></li><li class="nav-menu-item"><a href="https://www.schnepsmedia.com/upcoming-events/">Business Events</a></li><li class="nav-menu-item"><a href="https://games.metro.us/?arkpromo=Site_TopNav">Games</a></li></ul><ul class="nav-menu-items nav-menu-pile nav-menu-singlet-group">
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://jobs.metrophiladelphia.com/" target="_blank"><i class="fas fa-user-tie"></i>Jobs</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://bestof.metro.us/" target="_blank">Best of</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://phillysportsnetwork.com/" target="_blank"><i class="fas fa-baseball-ball"></i>Philly Sports Network</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="/category/politics/">Politics</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="/contact-us/">Contact Us</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="/category/digital-editions/">Digital Editions</a>
			</li></ul><ul class="nav-menu-items nav-menu-pile nav-menu-singlet-group">
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://simplecirc.com/subscribe/philadelphia-metro" target="_blank">Subscriptions</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://www.schnepsmedia.com/webinars/" target="_blank">Webinars</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://podcasts.schnepsmedia.com" target="_blank">Podcasts</a>
			</li>
			<li class="nav-menu-item nav-menu-subhead">
				  <a class="nav-menu-link" href="https://www.metro.us/sports/bet" target="_blank">MetroBet</a>
			</li>		
		<ul class="nav-menu-items">
			<li class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank">
				<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank">
				<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank">
				<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</li>
   		</ul>
		
		</ul>		
	</div>
	
</nav>
 

		</div>
	</div>

	 
<div class="content-container single-template transparent-container wallpaper-container">
<div class="container-center-cut">
	 

    <div class="content-section standard-singlepost">

        <div class="content-main">
        		            <article id="post-107136" class="post-107136 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-television tag-entertainment tag-television">
                <div class="article-header">
                    
                    			<div class="category-box category-label category-label-entertainment">
			<a href="https://metrophiladelphia.com/category/entertainment/">Entertainment</a>
			</div>
		                    
                    <h1 class="article-title">&#8216;The Dropout&#8217; star Naveen Andrews discusses playing Sunny Balwani</h1>
                    
                                            <div class="article-meta triple">
                            
							<span class="byline"><img alt='' src='https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png' srcset='https://metrophiladelphia.com/wp-content/uploads/2020/01/metro-logo-square.png 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/><span class="name">By <a href="https://metrophiladelphia.com/author/molly-given/" title="Posts by Molly Given" class="author url fn" rel="author">Molly Given</a></span></span>
														    <div class="comments-meta spotim-commentscount"><a href="#comments-anchor"><i class="far fa-comment-alt"></i> <div class="spot-im-replies-count" data-post-id="107136" real-time="true">0</div> comments</a></div>
							
							<span class="posted-on"><span class="intro">Posted on </span><a href="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/" rel="bookmark"><time class="entry-date published updated" datetime="2022-03-02T17:39:07-05:00">March 2, 2022</time></a></span>                            
                        </div><!-- .article-meta -->
                                        </div><!-- .article-header -->


                <!--<div class="post-thumbnail" style="max-width: 2560px;">-->
<div class="post-thumbnail">
	<div class="image-wrapper">
				
				<img width="1200" height="800" src="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1200x800.jpg" class="crop-center wp-post-image" alt="The Dropout" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-2048x1365.jpg 2048w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-900x600.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_00730rt-1600x1066.jpg 1600w" sizes="(max-width: 1200px) 100vw, 1200px" />			</div>
	<div class="image-caption">Sunny Balwani (Naveen Andrews) in &#8216;The Dropout.&#8217;</div>	<div class="image-credit">Beth Dubber/ Hulu</div></div><!-- .post-thumbnail -->

                <div class="addthis_inline_share_toolbox"></div>



                <div class="article-content">
                    <p class="promo-oneliner newsletter"><span><i class="far fa-envelope" aria-hidden="true"></i></span> <span>Sign up for <a class="PicoRule" href="#">our Daily Email newsletter</a> to stay up-to-date on the latest local news throughout Philadelphia.</span></p><div class="at-above-post addthis_tool" data-url="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/"></div><div id="pico"><p>When Theranos, the once-deemed &#8220;breakthrough health technology company&#8221; was found to be a complete fraud, the face of the corporation, Elizabeth Holmes, became a household name. As the case against the crooked organization began to unravel, so did everyone involved with Theranos, including Ramesh &#8220;Sunny&#8221; Balwani—former president and chief operating officer of the company, and Holmes&#8217; ex-boyfriend.</p>
<p><a href="https://metrophiladelphia.com/hulus-latest-film-reminds-us-life-is-about-the-little-things/">Hulu&#8217;s</a> new limited series, &#8216;The Dropout&#8217; focuses on the inner-workings of the operation and how good intentions from Holmes (played by <a href="https://metrophiladelphia.com/theres-more-than-what-meets-the-eye-in-things-heard-and-seen/">Amanda Seyfried</a>) went bad, and love from Balwani (played by Naveen Andrews) went wrong.</p>
<p>To give more context on what Balwani might have went through, Andrews sat down to chat with Metro about making the new series, which premieres March 3 on the streaming platform.</p>
<figure id="attachment_107170" aria-describedby="caption-attachment-107170" style="max-width: 700px" class="wp-caption alignnone"><img loading="lazy" class="size-medium wp-image-107170" src="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-700x467.jpg" alt="The Dropout" width="700" height="467" srcset="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-900x600.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_107_bd_05267rt-1600x1067.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption id="caption-attachment-107170" class="wp-caption-text"><span class="image-caption">Sunny Balwani (Naveen Andrews) and Elizabeth Holmes (Amanda Seyfried) star in &#8216;The Dropout.&#8217; </span><span class="image-credit">Beth Dubber/ Hulu</span></figcaption></figure>
<p><strong>What was it about this project that made you want to sign on? </strong></p>
<p>I was aware of the story when it broke&#8230;you couldn&#8217;t fail to be, it was everywhere. But, I wasn&#8217;t deeply interested because it had to do with companies and business and stocks—I didn&#8217;t find that particularly interesting. It was only when I got the script that I realized there were other dimensions to this story, which were almost Shakespearean. I thought &#8216;Macbeth&#8217; to be honest. Then of course, the quality of Liz&#8217;s (<a href="https://metrophiladelphia.com/jake-johnson-talks-making-a-comedy-with-heart-during-a-pandemic/">Meriwether</a>) writing, and then the idea that you can get that far with initially good intentions and what might happen on that journey&#8230;you don&#8217;t see that very often. It was deeply unsettling in a way.</p>
<p><strong>What aspects of this story are Shakespearean to you ?</strong></p>
<p>Well, from Sonny&#8217;s point of view: If there is a romantic aspect to his story and his significance, perhaps in her story, it&#8217;s the fact that he&#8217;s besotted with her and I think he still is—even after the trial. It&#8217;s how far would you go for love? What will you do if you love somebody that deeply?</p>
<p><strong>As an actor, how do you approach playing a role based on a real person in &#8216;The Dropout&#8217;? Especially one who is only really known for such a crazy and public story?</strong></p>
<p>There&#8217;s a certain amount of academic research that you can and must do. In terms of his generation and where he was born, to me it was significant [that] he was born in the Sindh province in what is now Pakistan. If you&#8217;re Hindu, to have to move because of discrimination or outright risk to your life and livelihood&#8230; I think that does something to you in terms of identity [and] in terms of displacement. There&#8217;s an emotional connection there, even though this person is quite remote from me. I think Amanda felt this as well, we have to approach these people as human beings. It was imperative not to make judgments or have preconceived notions about what we felt was morally right or wrong, or our notions of what is right or wrong that we&#8217;ve all got—hopefully, they&#8217;re similar but everyone&#8217;s different. So we had to throw that out really&#8230;you can&#8217;t play a human being if you&#8217;re making judgments about them.</p>
<figure id="attachment_107171" aria-describedby="caption-attachment-107171" style="max-width: 700px" class="wp-caption alignnone"><img loading="lazy" class="size-medium wp-image-107171" src="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-700x467.jpg" alt="The Dropout" width="700" height="467" srcset="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-900x600.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_105_bd_00914rt-1600x1067.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption id="caption-attachment-107171" class="wp-caption-text"><span class="image-caption">Sunny Balwani (Naveen Andrews) in &#8216;The Dropout.&#8217; </span><span class="image-credit">Beth Dubber/ Hulu</span></figcaption></figure>
<p><strong>How would you describe Sunny and what he goes through?</strong></p>
<p>One of the things that&#8217;s occurred to me is that, on a surface level, presentation is very important. It is for both of them. Her presentation—iconography if you like—and his, I have to say somewhat aggressive shield. His overprotectiveness in a sense. [It] masks something a lot deeper which rightly or wrongly, I felt was great insecurity behind all that. [It&#8217;s] to do with where he&#8217;s from and the whole immigrant ethos, because there&#8217;s always something behind what people present and their apparent confidence and display of ego.</p>
<p><strong>It&#8217;s interesting timing with the release of this show because Sunny&#8217;s trial is coming up very soon. What are your feelings on what he&#8217;s about to go through?</strong></p>
<p>Well, both of us again have felt this strange—there&#8217;s no other way to describe it—you become emotionally involved. So, you&#8217;re almost protective. It gets confusing because what we&#8217;ve created of our characters, their characters. But then, that can kind of blur and it extends to the real person. You can&#8217;t help that. But that&#8217;s a good thing I think, as odd as that may seem. I think things are working in terms of our piece if we are emotionally involved.</p>
<p><strong>I&#8217;m assuming you didn&#8217;t get to talk to him before filming &#8216;The Dropout&#8217;?</strong></p>
<p>I think it was a good thing—even if that had been available—in terms of what I&#8217;ve said about making judgments. I did look at his Twitter feed, and if I had an ounce of that self-worth I&#8217;d be a lot happier person I think. But again, that&#8217;s a judgment I&#8217;ve made, yeah? At some point it would be nice to meet the actual person. But in terms of what we were creating, it wouldn&#8217;t be so helpful.</p>
<p><strong>So you would meet him now? What would you talk about?</strong></p>
<p>Yes. If I had a question, just for me&#8230; it may be very difficult for him to answer, but I would ask: Do you believe that she loved you? Do you believe it? Does that sustain you? That&#8217;s what I would ask, and it&#8217;s a very personal question. He would probably tell me to f**k off.</p>
<figure id="attachment_107172" aria-describedby="caption-attachment-107172" style="max-width: 700px" class="wp-caption alignnone"><img loading="lazy" class="size-medium wp-image-107172" src="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-700x467.jpg" alt="The Dropout" width="700" height="467" srcset="https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-900x600.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2022/02/dropout_101_bd_01418rt-1600x1067.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption id="caption-attachment-107172" class="wp-caption-text"><span class="image-credit">Beth Dubber/ Hulu</span></figcaption></figure>
<p><strong>What do you think it was about Elizabeth that really enthralled Sunny Balwani to go so deep?</strong></p>
<p>Well, I myself am somewhat perplexed as to what it was. But for him, I believe it was almost like a creation. I think there&#8217;s a line later on where he specifically [says that it] feels like you almost design and create somebody&#8230;And in a way we all do that to some extent perhaps in a romantic relationship. If you create a fiction say in your own mind and heart perhaps—that can be very powerful. Particularly that creation is cherished by you. Quite sad as well, and the stakes are very high.</p>
<p><strong>With this highly publicized case, will &#8216;The Dropout&#8217; give audiences much more detail that will surprise them about the Theranos case?</strong></p>
<p>I would certainly hope so. And perhaps a general, broader question about: Is it right that these entrepreneurs, for want of a better term, are allowed un-channeled power and wealth and control over other people&#8217;s lives? I think if it raises that question it&#8217;s a good thing.</p>
<p><em>&#8216;The Dropout&#8217; premieres on <a href="https://www.hulu.com/profiles?next=/series/the-dropout-13988f84-f1c8-40dd-a73c-4e71ab4bbe63" target="_blank" rel="noopener">Hulu</a> March 3.  </em></p>
</div><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://metrophiladelphia.com/the-dropout-star-naveen-andrews-discusses-playing-sunny-balwani/"></div><!-- AddThis Share Buttons generic via filter on the_content -->
                    
                </div><!-- .article-content -->

                <div class="article-footer">

                    
                    <div class="addthis_inline_share_toolbox"></div>

                    <div class="author-meta">
                        	<h3 class="about-the-author">About the Author</h3>
 
                    </div>

                    						<div class="comments-container">
                            <div data-spotim-module="conversation" data-post-id="107136"></div>
						</div>
										
					
                    					
                </div><!-- .article-footer-->
            </article>

		        </div>
		<div class="sidebar-section widget-area">
            <section class="featured_jobs_widget widget">
<div class="top-posts featured featured-jobs">
<h2 class="widget-title"><a href="https://jobs.metrophiladelphia.com" target="_blank">Featured Jobs</a></h2>
<h4 class="widget-add-yours"><a href="https://jobs.metrophiladelphia.com/list-your-job/" target="_blank" class="basic-button bkg-main"><i class="fas fa-user-plus"></i>Add your job</a></h4>
<ul class="display-posts-listing">
<li class="listing-item article-container cards-design"><span class="title-wrapper"><a class="title" href="https://jobs.metrophiladelphia.com/2022/02/28/were-hiring-adults-and-teens-for-our-fab-summer-job-program/" target="_blank"><span class="company-name"><i class="fas fa-building"></i>Fab Youth Philly</span><span class="job-title">We&#8217;re hiring adults and teens for our FAB summer job program</span></a></span>
</li>
		</ul>
<h4 class="widget-add-yours"><a href="https://jobs.metrophiladelphia.com" class="basic-button bkg-main" target="_blank">View all jobs…</a></h4>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_1 -->
<div id='div-gpt-ad-1570802487184-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570802487184-0'); });
  </script>
</div>
</div>
</section>
<section class="widget_promo widget optional"><div class="top-posts news">
<h2 class="widget-title">News</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/bring-your-appetite-northern-liberties-restaurant-week-returns-in-april/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/NL_RW_Anejo-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/bring-your-appetite-northern-liberties-restaurant-week-returns-in-april/">Bring your appetite: Northern Liberties Restaurant Week returns in April</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/born-in-a-war-kyiv-maternity-hospital-carries-on-under-siege/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/2022-03-02T200607Z_1_LYNXMPEI2115X_RTROPTP_4_UKRAINE-CRISIS-KYIV-MATERNITY-HOSPITAL-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/born-in-a-war-kyiv-maternity-hospital-carries-on-under-siege/">Born in a war: Kyiv maternity hospital carries on under siege</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/philly-drops-indoor-mask-mandate-plans-to-lift-school-requirement/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2021/11/2021-11-10T135512Z_3_LYNXMPEHA90W4_RTROPTP_4_USA-ECONOMY-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/philly-drops-indoor-mask-mandate-plans-to-lift-school-requirement/">Philly drops indoor mask mandate, plans to lift school <span class="lgwd">requirement</span></a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/police-kill-teen-in-south-philly/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/02/DSC_0309-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/police-kill-teen-in-south-philly/">Boy, 12, fatally shot by police in South Philly</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/rent-brings-25th-anniversary-farewell-tour-to-kimmel-cultural-campus/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/RENT-16-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/rent-brings-25th-anniversary-farewell-tour-to-kimmel-cultural-campus/">‘Rent’ brings 25th <span class="lgwd">anniversary</span> farewell tour to Kimmel Cultural Campus</a></span></li></ul>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_2 -->
<div id='div-gpt-ad-1570821891441-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570821891441-0'); });
  </script>
</div>
</div>
</section><section class="widget_promo widget optional"><div class="top-posts arts">
<h2 class="widget-title">Entertainment</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/chef-steek-kevin-cooper-competes-and-wins/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/9E92604E-7E82-479A-B142-E584DC0CB0BB-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Kevin Cooper" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/chef-steek-kevin-cooper-competes-and-wins/">Philly native Kevin Cooper talks latest Food Network win</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/bring-your-appetite-northern-liberties-restaurant-week-returns-in-april/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/NL_RW_Anejo-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/bring-your-appetite-northern-liberties-restaurant-week-returns-in-april/">Bring your appetite: Northern Liberties Restaurant Week returns in April</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/rent-brings-25th-anniversary-farewell-tour-to-kimmel-cultural-campus/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/RENT-16-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/rent-brings-25th-anniversary-farewell-tour-to-kimmel-cultural-campus/">‘Rent’ brings 25th <span class="lgwd">anniversary</span> farewell tour to Kimmel Cultural Campus</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/a-golden-girls-murder-mystery-comes-to-craft-hall/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/DSC_4586-1-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="A Golden Girls Murder Mystery" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/a-golden-girls-murder-mystery-comes-to-craft-hall/">&#8216;A Golden Girls Murder Mystery&#8217; comes to Craft Hall</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/celebrate-womens-history-month-with-chef-kiki-aranita/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/Kiki-and-sauce-by-Mike-Prince-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="things to do in Philly" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/celebrate-womens-history-month-with-chef-kiki-aranita/">Celebrate Women&#8217;s History Month with Chef Kiki Aranita</a></span></li></ul>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_3 -->
<div id='div-gpt-ad-1570821979731-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570821979731-0'); });
  </script>
</div>
</div>
</section><section class="widget_promo widget optional"><div class="top-posts sports">
<h2 class="widget-title">Sports</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design post-format-link"><a class="image" href="https://www.amny.com/sports/mlb-lockout-league-mlbpa-hold-informal-talks/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/2019-04-06T000344Z_826553413_NOCID_RTRMADP_3_MLB-TAMPA-BAY-RAYS-AT-SAN-FRANCISCO-GIANTS-1200x800-1-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.amny.com/sports/mlb-lockout-league-mlbpa-hold-informal-talks/">MLB lockout: League, MLBPA hold informal talks</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/its-a-miracle-were-here-ukraine-team-arrive-in-beijing/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/2022-03-03T123346Z_1_LYNXNPEI220P8_RTROPTP_4_PARALYMPICS-2022-BIATHLON-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/its-a-miracle-were-here-ukraine-team-arrive-in-beijing/">&#8216;It&#8217;s a miracle we&#8217;re here&#8217;: Ukraine team arrive in Beijing for Winter <span class="lgwd">Paralympics</span></a></span></li><li class="listing-item article-container cards-design post-format-link"><a class="image" href="https://www.amny.com/sports/rob-manfred-mlb-oped-lockout/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/2019-10-02T233026Z_1458420170_NOCID_RTRMADP_3_MLB-AL-WILD-CARD-TAMPA-BAY-RAYS-AT-OAKLAND-ATHLETICS-1200x800-1-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.amny.com/sports/rob-manfred-mlb-oped-lockout/">Ineptitude of Rob Manfred, greed of MLB has alienated players, fans with Opening Day 2022 on hold</a></span></li><li class="listing-item article-container cards-design post-format-link"><a class="image" href="https://www.amny.com/sports/world-athletics-ban-russia-belarus/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/03/2022-03-01T171356Z_1_LYNXMPEI202FG_RTROPTP_4_ATHLETICS-CORRUPTION-1200x800-1-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.amny.com/sports/world-athletics-ban-russia-belarus/">World Athletics joins sporting bodies in banning Russian and Belarusian athletes</a></span></li><li class="listing-item article-container cards-design post-format-link"><a class="image" href="https://www.amny.com/sports/mlb-lockout-deadline-pushed-back-tuesday/"><img width="192" height="192" src="https://metrophiladelphia.com/wp-content/uploads/2022/02/sptn_citi_field_0506-1024x683-1-192x192.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.amny.com/sports/mlb-lockout-deadline-pushed-back-tuesday/">MLB lockout: Owner&#8217;s deadline pushed back to Tuesday after marathon meeting</a></span></li></ul>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_4 -->
<div id='div-gpt-ad-1570823235622-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823235622-0'); });
  </script>
</div>
</div>
</section>
        </div>
    </div><!-- #main -->

	 
</div>
</div><!-- #primary -->

<div class="ad-container content-ad-container">
<!-- /1048906/metro_philly_desktop_ros_leader_2 -->
<div id='div-gpt-ad-1570823321511-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823321511-1'); });
  </script>
</div>
</div> 

<div class="component-container popular-in-the-community">
	<div class="popularcommunity-container">
		<div data-spotim-module="pitc"></div>
	</div>
</div>
<div class="component-container related-posts">
<div class="related-posts-footer">
<h2 class="related-title">Related Articles</h2>
<!-- related posts -->
	<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/city-so-real-shows-that-chicagos-problems-are-americas-problems/"><img width="700" height="394" src="https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-700x394.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-700x394.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-1200x675.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-768x432.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-1536x864.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-384x216.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-900x506.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2020/10/Ep101_CitySoReal_07-copy-1600x900.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/city-so-real-shows-that-chicagos-problems-are-americas-problems/">&#8216;City So Real&#8217; shows that Chicago&#8217;s problems are &#8220;America&#8217;s problems&#8221;</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/dan-byrd-on-how-utopia-will-resonate-now-more-than-ever/"><img width="700" height="467" src="https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-700x467.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-700x467.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-1200x800.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-768x512.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-1536x1024.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-384x256.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-900x600.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2020/09/utopia-UPIA_S1_Unit_103_2128R2C_rgb-1600x1067.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/dan-byrd-on-how-utopia-will-resonate-now-more-than-ever/">Dan Byrd on how &#8216;Utopia&#8217; will resonate now more than ever</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/opera-philadelphias-hbo-like-channel-sets-premiere-date/"><img width="700" height="700" src="https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-700x700.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-700x700.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-1200x1200.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-192x192.jpg 192w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-768x768.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-1536x1536.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-384x384.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee-900x900.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2020/09/1-Lawrence-Brownlee.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/opera-philadelphias-hbo-like-channel-sets-premiere-date/">Opera <span class="lgwd">Philadelphia&#8217;s</span> &#8216;HBO-like&#8217; channel sets premiere date</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://metrophiladelphia.com/worlds-toughest-challenge-truly-showcases-the-will-of-human-spirit/"><img width="700" height="466" src="https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-700x466.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-700x466.jpg 700w, https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-1200x798.jpg 1200w, https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-768x511.jpg 768w, https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-1536x1022.jpg 1536w, https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-384x255.jpg 384w, https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-900x599.jpg 900w, https://metrophiladelphia.com/wp-content/uploads/2020/08/world-s-toughest-race-eco-challenge-fiji-ECCH_S1_Unit_Rich_004415R_rgb-1600x1065.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://metrophiladelphia.com/worlds-toughest-challenge-truly-showcases-the-will-of-human-spirit/">&#8216;World&#8217;s Toughest Challenge&#8217; truly showcases the will of human spirit</a></span></li></ul>
</div>
</div> 

<div class="hero-container sister-sites-container component-container card" style="background: #000e0a">

	<div class="component-title-section">
		<h2 class="section-title">More from our Sister Sites</h2>
	</div>

    <div class="hero-section sister-sites component-content-section hero-blocks-4">
    				<article class="article-container cards-design">
					<a href="https://www.caribbeanlife.com/myrie-pandemic-fraud-bill-passes-senate-committee/"><img width="412" height="400" src="https://www.caribbeanlife.com/wp-content/uploads/2019/12/2019-12-06-nk-early-voting-hearing-cl01_z.jpg" class="crop-top wp-post-image" alt="" loading="lazy" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-caribbean-life"><a href="https://www.caribbeanlife.com">Caribbean Life</a></div>
				<h2><a href="https://www.caribbeanlife.com/myrie-pandemic-fraud-bill-passes-senate-committee/">Myrie pandemic fraud bill passes <span class="titend">Senate committee</span></a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://www.amny.com/police-fire/courts/trump-to-turn-over-documents-in-new-york-civil-probe-need-not-testify-during-appeal/"><img width="700" height="462" src="https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-700x462.jpg" class="crop-center wp-post-image" alt="" loading="lazy" srcset="https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-700x462.jpg 700w, https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-1200x792.jpg 1200w, https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-768x507.jpg 768w, https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-1536x1013.jpg 1536w, https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-384x253.jpg 384w, https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-900x594.jpg 900w, https://www.amny.com/wp-content/uploads/2022/03/2022-03-03T210026Z_1_LYNXNPEI221BI_RTROPTP_4_USA-TRUMP-NEW-YORK-1600x1056.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-amny"><a href="https://www.amny.com">AMNY</a></div>
				<h2><a href="https://www.amny.com/police-fire/courts/trump-to-turn-over-documents-in-new-york-civil-probe-need-not-testify-during-appeal/">Trump to turn over documents in New York civil probe, need not testify <span class="titend">during appeal</span></a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://podcasts.schnepsmedia.com/2022/03/02/revitalizing-business-in-queens-tom-grech-president-queens-chamber/"><img width="800" height="407" src="https://podcasts.schnepsmedia.com/wp-content/uploads/2022/03/Tom-Grech_Banner-800x407.jpg" class="crop-center no-crop wp-post-image" alt="" loading="lazy" srcset="https://podcasts.schnepsmedia.com/wp-content/uploads/2022/03/Tom-Grech_Banner-800x407.jpg 800w, https://podcasts.schnepsmedia.com/wp-content/uploads/2022/03/Tom-Grech_Banner-768x390.jpg 768w, https://podcasts.schnepsmedia.com/wp-content/uploads/2022/03/Tom-Grech_Banner-384x195.jpg 384w, https://podcasts.schnepsmedia.com/wp-content/uploads/2022/03/Tom-Grech_Banner-900x458.jpg 900w, https://podcasts.schnepsmedia.com/wp-content/uploads/2022/03/Tom-Grech_Banner.jpg 1080w" sizes="(max-width: 800px) 100vw, 800px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-schneps-podcasts"><a href="https://podcasts.schnepsmedia.com">Schneps Podcasts</a></div>
				<h2><a href="https://podcasts.schnepsmedia.com/2022/03/02/revitalizing-business-in-queens-tom-grech-president-queens-chamber/"><span class="lgwd">Revitalizing</span> Business in Queens with Tom Grech, President and CEO, Queens Chamber <span class="titend">of Commerce</span></a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://gaycitynews.com/rendezvous-with-french-cinema-offers-three-queer-films/"><img width="700" height="467" src="https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-700x467.jpg" class="crop-center wp-post-image" alt="" loading="lazy" srcset="https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-700x467.jpg 700w, https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-1200x800.jpg 1200w, https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-768x512.jpg 768w, https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-1536x1024.jpg 1536w, https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-384x256.jpg 384w, https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-900x600.jpg 900w, https://gaycitynews.com/wp-content/uploads/2022/03/PARIS-13TH-DISTRICT-Still-2-1600x1067.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a>					<div class="context-box">
				<div class="blurb category-label site-label-gay-city-news"><a href="https://gaycitynews.com">Gay City News</a></div>
				<h2><a href="https://gaycitynews.com/rendezvous-with-french-cinema-offers-three-queer-films/">Rendezvous with French Cinema Offers Three <span class="titend">Queer Films</span></a></h2>
					</div>
				</article>
				    </div>
</div>


    <footer class="site-footer">

        	<nav class="footer-nav-menu"><ul>
							<li>
			<a class="" href="/newsletter/" target="">
			<span>Newsletter</span>
			</a>
		</li>
							<li>
			<a class="" href="https://www.calameo.com/subscriptions/6610671" target="_blank">
			<span>Digital Editions</span>
			</a>
		</li>
							<li>
			<a class="" href="/contact-us/" target="">
			<span>Contact Us</span>
			</a>
		</li>
							<li>
			<a class="" href="https://www.schnepsevents.com/ " target="">
			<span>Networking Events</span>
			</a>
		</li>
							<li>
			<a class="" href="https://philly.metro.us/advertise" target="">
			<span>Advertise</span>
			</a>
		</li>
		
	
			<li class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank">
				<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank">
				<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank">
				<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</li>
		
	</ul></nav>
 

        	<nav class="site-info"><ul>
													<li class="copyright">
			<a href="https://www.schnepsmedia.com/" target="_blank">
			<span>© 2022 Schneps Media</span>
			</a>
		</li>
													<li class="">
			<a href="/privacy-policy/" target="">
			<span>Privacy Policy</span>
			</a>
		</li>
													<li class="">
			<a href="/terms/" target="">
			<span>Terms of Use</span>
			</a>
		</li>
		</ul></nav>
 

    </footer>
	
</div> <!--#grid-wrappr-->	

<nav id="theStickyNavBar" class="sticky sticky-fa sticky-bottom-bar" role="navigation">
	<ul>
					
				<li class="hamburger">
					<span class="sticky-item">
					<i class="fas fa-bars opener"></i>
					Sections
					</span>
				</li>

											
				<li class="">
					<a class="sticky-item" href="https://www.calameo.com/subscriptions/6610671" target="_blank" title="">
					<i class="far fa-newspaper"></i>					Editions					</a>
				</li>
											
				<li class="">
					<a class="sticky-item" href="/contact-us/" target="" title="">
					<i class="fas fa-phone"></i>					Contact					</a>
				</li>
											
				<li class="">
					<a class="sticky-item" href="https://games.metro.us/?arkpromo=StickyMenu" target="_blank" title="">
					<i class="fas fa-gamepad"></i>					Games					</a>
				</li>
											<li class="PicoManageAccount nav-menu-newsletter">
					<a class="sticky-item" href="/newsletter/" target="" title="">
					<i class="fas fa-envelope"></i>					Manage
					</a>
				</li>
									
				<li class="PicoRule nav-menu-newsletter">
					<a class="sticky-item" href="/newsletter/" target="" title="">
					<i class="fas fa-envelope"></i>					Sign Up					</a>
				</li>
			
			
			</ul>        
</nav> 

<div id='pico-widget-container'></div><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-f5ecca744013cbc75a73ab967a93c239","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.8.3#pubid=ra-5efa2cdec328d553' id='addthis_widget-js'></script>
<script type='text/javascript' id='theme-js-js-extra'>
/* <![CDATA[ */
var ajax_controller = {"ajax_url":"https:\/\/metrophiladelphia.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/themes/schnepstheme/build/bundle.cb128eca.js' id='theme-js-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-content/themes/schnepstheme-philly/build/bundle.3eceeff2.js' id='child-theme-js-js'></script>
<script type='text/javascript' src='https://metrophiladelphia.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script>

<!-- /1048906/metro_philly_ros_pixel_1x1 -->
<div id='div-gpt-ad-1570992069741-0' style='width: 1px; height: 1px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570992069741-0'); });
  </script>
</div>
 

</body>
</html>
